Opened 12 years ago

Closed 12 years ago

#271 closed task (fixed)

Other facility templates - check function

Reported by: srkline Owned by: srkline
Priority: minor Milestone: General Package Release Tasks
Component: SANS Reduction Keywords:
Cc: Blocking:
Task:

Description

with the new loader in the Igor Procedures, and all of the other changes, how does this affect the other templates?

Change History (3)

comment:1 Changed 12 years ago by srkline

Other facility templates seem to function, as far as I can tell.

There is, however one BIG clash. That is loading another facility reduction, then (any) NCNR package. That is because the FACILITY_Utils and the NCNR_Utils are then both in the same experiment. By design, they're not supposed to be in the same experiment.

One possible workaround is to replace the NCNR_Package_Loader (or make it smart to know which facility is defined) with one that will not try to load mixed NCNR_ files and other facility files. Not easy...

comment:2 Changed 12 years ago by srkline

All templates seem to work fine now, as much as I can test them.

Now, when a non-NCNR reduction template is loaded, the NCNR_Package_Loader.ipf is closed, so that the packages can't be accidentally loaded into an experiment. It is an integral part of the initialization routine now.

The ony drawback to this is that the procedure is now not available until Igor is quit/reopened since it was loaded at startup from the Igor Procedures folder.

Is this really an issue worth chasing down a solution?

comment:3 Changed 12 years ago by srkline

  • Resolution set to fixed
  • Status changed from new to closed

they all seem to work now, but I have no ANSTO data to really test anything, other than it compiles. HFIR works (Andrea's data) and ILL works (Lionel's data).

Note: See TracTickets for help on using tickets.