Opened 15 years ago

Closed 15 years ago

#56 closed feature (worksforme)

Need consistent naming scheme for Plot* macros

Reported by: srkline Owned by: srkline
Priority: major Milestone: Analysis_4.0_Beta
Component: Analysis Keywords:
Cc: Blocking:
Task: Interface

Description

A consistent naming scheme for the Plot* macros will allow the macros to be called if the function is known, simply by constructing the "Plot"+funcStr command. This will enable automatic plotting and appending of models, without the need to use the "Append to graph..." menu selection and the now messier DataFolder? dependent dialog.

This means a lot of hand changes to every function (ipf) and corresponding changes to funcX names in the XOP

Change History (3)

comment:1 Changed 15 years ago by srkline

  • Status changed from new to assigned

done, needs to be fully tested w/repeated plot and append or some sort of clever automated test

comment:2 Changed 15 years ago by srkline

the following XOP names need to be updated to match the new naming scheme:


#if exists("CoreShellSphereX")

#if exists("PolyHardSpheresX")

#if exists("MultiShellSphereX")

#if exists("LogNormalSphereX")

#if exists("GaussSpheresX")

convert 20pt function to this
#if exists("EllipticalCylinderX")


comment:3 Changed 15 years ago by srkline

  • Resolution set to worksforme
  • Status changed from assigned to closed

The plot and append has been tested from the wrapper panel in an automated fashion, and appears to work.

All of the current model functions have been udpated to the consistent naming scheme.

The XOP names have been changed to match as well.

Note: See TracTickets for help on using tickets.