Opened 6 years ago

Closed 4 years ago

#572 closed bug (fixed)

SLD solvent not refreshing after a number is input for LogNormalSphereHS

Reported by: sjn464@… Owned by: srkline
Priority: major Milestone:
Component: Analysis Keywords: LogNormalSphere
Cc: m.laver@… Blocking:
Task:

Description

When the difference between the SLD of the solvent and spheres is kept constant whilst varying the numbers, the graph displays differing values. I.e. SLD sphere = 2e-06 and SLD Solvent = 1e-06 plots a different graph to 3e-06 and 2e-06 respectively. Bug confirmed by Dr. Mark Laver, University of Birmingham, Materials and Metallurgy Dept.

Change History (2)

comment:1 Changed 6 years ago by srkline

tried to duplicate this, but couldn't. asked for more specifics on what sequence they used to cause the bug.

Noticed a few instances of "UpdtDisplay?: Recursion Attempted" in the command window, but I don't know if they were related. I was trying a lot of things, and tracking bugs in the LamellarParacrystalline? model too, so I don't know what led to the recursion.

the XOP/non-XOP versions of the LogNormalSphere? calculation did act a bit odd, occasionally returning NaN for the whole wave - and then magically correcting itself if I re-plotted... not sure what's going on with that, but can't reproduce that either.

comment:2 Changed 4 years ago by srkline

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.