Opened 4 years ago

Closed 4 years ago

#629 closed bug (fixed)

NaN in reduced data files

Reported by: srkline Owned by: srkline
Priority: major Milestone: VSANS Reduction
Component: All Components Keywords:
Cc: Blocking:
Task:

Description

Need to be sure that NaN values do not appear in the output I(q) files. If they do appear, then the data analysis usually has problems - the resolution matrix cannot be calculated, or NLLSQ fitting returns nonsense.

To remedy - identify if it happens, and use a larger mask (if this is really the cause) or simply identify and remove these points before saving.

Change History (2)

comment:1 Changed 4 years ago by srkline

  • Milestone set to VSANS Reduction

comment:2 Changed 4 years ago by srkline

  • Resolution set to fixed
  • Status changed from new to closed

added a function to remove NaN values

Note: See TracTickets for help on using tickets.