Opened 2 years ago

Closed 2 years ago

#675 closed bug (fixed)

Patch XY panel not updating values

Reported by: srkline Owned by: srkline
Priority: major Milestone: VSANS Reduction
Component: All Components Keywords:
Cc: Blocking:
Task:

Description

From Markus --

I used the Patch_x_y_Panel quite intensively in the last days, since the user measured data with different Cd masks and the only way I could think of is letting him do his thing and patch the direct beam afterwards..
The problem is quite simple, I opened the panel, read in some values over a range, wrote the values over the same range and then increased the upper file number to jump inside the original interval before pressing Read in order to see if this file had changed its direct beam positions, which it did not.
Exactly the same procedure after a fresh restart of Igor produced the desired result.

Change History (1)

comment:1 Changed 2 years ago by srkline

  • Resolution set to fixed
  • Status changed from new to closed

patch XY panel now deletes each file from rawVSANS as it is patched so that it forces a re-read from disk, rather picking up stale values from internal data folders. Not sure which revision included this change, but it was corrected in the past.

Note: See TracTickets for help on using tickets.